When you create a BLT Installer for your product, you can select Run-Time Engines to include with it.


Select in the list on the left which Run-Time Engine(s) you want to include with your installer and click the "Right Arrow" button to add them in the list on the right.

Type a keyword in "Search String" and press "Enter" to help you finding the right installer.

Use the "Left Arrow" button to remove an installer from your selection "right list)

You can define the order of installation of  selected installers by moving them in the list on the right (drag and drop)

Click "OK" to add the selected NI Installers to your product installer.


When you include a Run-Time Engine in a BLT installer, BLT downloads the file from National Instrument's website on your computer and keep it for future use in the BLT installation directory.


Note: Since 2019, NI uses NI Package Manager to release their software and drivers. BLT for LabVIEW is not yet compatible with NI Package Manager, and therefore, the BLT Installer feature only allows to include Run-Time Engines up to version 2018 (included).

If you need to create an Installer for your Product and want to include Run-Time Engine Installers for versions 2019 and greater, you can build a regular NI Installer from your LabVIEW Project as described here: Distribute your Product using the NI Installer